keepalivedをインストールするには。。


configureした時に以下のようなエラーメッセージが出た場合、

  !!! OpenSSL is not properly installed on your system. !!!
  !!! Can not include OpenSSL headers files.            !!!

↓↓↓↓

yum install openssl-devel

因みにIPVSと同じバージョンでないと、makeする際にこんなエラーも出ますのでご注意を。。。

/usr/src/linux/include/linux/types.h:142: error: previous declaration of ‘blkcnt_t’ was here
make[2]: *** [ip_vs_nl_policy.o] エラー 1
make[2]: ディレクトリ `/usr/local/src/keepalived-1.2.2/keepalived/libipvs-2.6' から出ます
make[1]: *** [all] エラー 1
make[1]: ディレクトリ `/usr/local/src/keepalived-1.2.2/keepalived' から出ます
make: *** [all] エラー 2

以上、メモでした!!

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です